关于在一些运行在Virtual Box中的稍旧版本的Cent OS与VB Tools的安装问题

稍旧版本的Centos7在安装VB Tools时会报错并提示安装kernel-devel

解决办法:
首先确保安装了gcc、make、perl:

yum install gcc make perl -y

其次在安装报错后更新一下系统中所有的软件:

yum upgrade -y

在更新了软件后重启就会发现问题神奇的解决了
PS:
报错信息大致如下:

This system is currently not set up to build kernel modules.
Please install the Linux kernel “header” files matching the current kernel
for adding new hardware support to the system.
The distribution packages containing the headers are probably:
kernel-devel kernel-devel-3.10.0-693.11.1.el7.x86_64