npm更新出错-/usr/local/lib/node_modules/npm/bin/npm-cli.js:79 let notifier = require('update-notifier')

在安装更新时出现如标题的错误:/usr/local/lib/node_modules/npm/bin/npm-cli.js:79 let notifier = require(‘update-notifier’),后经搜索找到解决办法:
第一步:/usr/bin/npm uninstall npm
第二步:rm -r /usr/local/lib/node_modules/npm
本人环境:运行于物理环境为Ubuntu16.04的VPS中的Docker(容器使用基于Ubuntu16.04基础镜像定制的魔改版)容器。
出现如上错误的原因为安装了错误版本的npm与nodejs,导致不兼容。